Added new Storage Link to Odrive But It Doesn't Show up in my Odrive Folder on Mac

I added the link to Storage for a Slack Workspace.

It shows and I can browse it in the WebGUI, but it doesn’t sync to my local (mac) machine. ON the Mac side I have resysnched but it still shows up. The documents lead me to believe that it should just show up.

I installed odrive last January, And I don’t recall if I had to do anything special to make my first two storage (Dropbox and Google Drive) show up in the local sync. Have searched, but haven’t turned up any advice on what to do in this case.

Looking for help.

Hi @coach,
What is the name of the new Slack link, as it is shown in the odrive web client? Does it have any special characters in it that could be preventing it from being shown on the Desktop?

Can you send a diagnostic from odrive menu on the desktop client so I can take a closer look?

Hi @Tony,

Thanks for your reply. Maybe I didn’t wait long enough for the slack sync to happen? I wrote this message on Saturday. On Monday everything was there on my odrive. So yeah probably didn’t wait long enough. I really like this Slack feature.


Thanks for the update @coach. Try a right-click->refresh next time and see if that triggers a quicker refresh for an added link.


Thanks again for your quick reply. I added a new service (this time an sftp link to my local NAS). And it’s not showing up. I tried to find the refresh (right click) and don’t find it.

Can you give me some more hints?


Hi @coach,
Have you tried the refresh under the odrive icon at top of the Finder window?

Try that while you are in the root of the odrive folder. This should force a refresh and show any new links within a few seconds. If it doesn’t can you send a diagnostic from the odrive tray menu?

Haha :slight_smile: I’d never noticed that icon before :slight_smile:

1 Like