Connecting clients to your gateway (Ports and Firewalls)

Connecting clients to your gateway (Ports and Firewalls)

Postby Tony » Fri Jan 31, 2014 12:35 am

There have been some questions coming in about this, so I want to address it in its own thread and also give our fine beta users a place to offer feedback, ask questions, or raise any issues.

The odrive gateway listens on port 8888 on all available network interfaces for incoming connections from odrive clients.

To ensure that remote clients can access the odrive gateway, you can route incoming connections on port 8888 to the local IP of the odrive gateway. Depending on your network infrastructure, the exact steps to achieve this can vary. I'll go through a simple example here, based on my home odrive gateway setup.

I'm running an old eeepc netbook (1005ha), fronting a 4TB Drobo-FS NAS. I'm currently running Windows 8 on it, but I will most likely switch it out for Linux soon ;). I have left everything to auto-configure on the odrive gateway.
gw_settings_sm.jpg
gw_settings_sm.jpg (29.11 KiB) Viewed 2065 times


In my case, allowing remote access took less than 5 minutes to setup:

1) Install the odrive gateway and invite a remote user.

2) Set a static IP on the eeepc (192.168.100.165). Alternatively, I could've set a static lease, to ensure the IP address assigned by the router would not change.

3) Set a port fowarding rule on the router from port 8888 (TCP) to port 8888 at 192.168.100.165

*Depending on your router, this screen may look different*
odrive_gw_port_map.jpg
odrive_gw_port_map.jpg (107.22 KiB) Viewed 2077 times

That's it!

Depending on your configuration and needs, you may have a couple more steps. Let me know if you need any assistance and I'll do my best to help you through it.
User avatar
Tony
 
Posts: 100
Joined: Tue Nov 19, 2013 2:47 pm

Re: Connecting remote odrive clients to your new odrive gate

Postby Tony » Tue Feb 18, 2014 3:47 pm

Even after completing the steps above, I have a feeling a some people are running into issues with Windows firewalls, so I wanted to add a quick note about that.

This is an easy way to add a firewall exception for port 8888, which is the port that the odrive gateway listens on. With this rule in place, odrive clients will not be turned away by the Windows firewall.

start-run1.jpg
start-run1.jpg (34.29 KiB) Viewed 1943 times

1) Click on Start->Run to open up the "Run" windows.
2) Copy and paste the following line into the field and press "enter":
cmd /c netsh advfirewall firewall add rule name=odrive dir=in action=allow protocol=TCP localport=8888 & pause

That's it!
User avatar
Tony
 
Posts: 100
Joined: Tue Nov 19, 2013 2:47 pm

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby KnotProfit » Wed Feb 19, 2014 5:20 pm

I'm not having any success. I'm using a motorola sbg6580 router. I'm running Odrive on a Mac Mini Server (I don't know the first thing about using it as a server though).

Everything works fine when I am on the same network, but when I test on a different network remotely I'm not having success. I've tried to set up the forwarding, but it looks a bit different for me. I have internal and external. I entered my internal IP as the connection I have through ethernet of my Mini. This lines up with the Private Address on the Gateway Manager App in settings.

Please help me figure out what I'm missing!

The image is not my screen, just a google image of what my interface looks like.
Image
KnotProfit
 
Posts: 11
Joined: Wed Feb 19, 2014 5:10 pm
Location: Cople, OH

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby Tony » Thu Feb 20, 2014 4:02 pm

Hi,

I don't have that particular router handy, but after a little research I think this may work for you:

Port Forwarding.JPG
Port Forwarding.JPG (21.58 KiB) Viewed 1923 times

You would need to put in the private IP address of the server in the appropriate spot. You can double-check this by trying to hit this URL from the browser of another machine: https://yourgatewayiphere:8888/status

Let me know how it goes!
User avatar
Tony
 
Posts: 100
Joined: Tue Nov 19, 2013 2:47 pm

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby KnotProfit » Thu Feb 20, 2014 6:34 pm

Hmm, well the only thing that I didn't have was the start/end port in the external column, but that still didn't seem to make a difference. Even though I bought the "server" I'm not really using it as such, so I'd expect for this to work as though I were setting it up on any other OSX computer.

I've got my local IP in the internal 8888 in both start/end ports for both internal and external, protocol at both, and enabled. The only thing that seems to be unique is that I have two local IPs, one through wifi, and one through Ethernet. I'm trying to use the Ethernet IP.
KnotProfit
 
Posts: 11
Joined: Wed Feb 19, 2014 5:10 pm
Location: Cople, OH

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby Tony » Thu Feb 20, 2014 7:45 pm

Hi,

I suppose its possible that there is a firewall enabled on the server. It could also be possible that the router has issues with port mapping, as I saw several complaints when doing the research for it.

What version of OS X are you running on the Mac Mini? Depending on the answer there could be a few different ways to check the firewall, but we can see if that might be it.
User avatar
Tony
 
Posts: 100
Joined: Tue Nov 19, 2013 2:47 pm

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby KnotProfit » Thu Feb 20, 2014 8:03 pm

I'm on Mavericks: 10.9.1. I can see if I can call my cable provider on Saturday to figure out if the port mapping is the issue.

Thanks!
KnotProfit
 
Posts: 11
Joined: Wed Feb 19, 2014 5:10 pm
Location: Cople, OH

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby KnotProfit » Sat Feb 22, 2014 3:57 pm

I just wanted to provide an update. I called Time Warner and got no support, so I'm going to try and just take in my router next week to have it swapped out; hopefully a different brand.

I also, contacted Apple and got confirmation that the OS has nothing built into it that could inhibit the port forward other than the firewall which is turned off. Lastly, I tried setting up the forward on my Macbook Air and tested with the link that you provided above. Still no dice. I hope that I can get a new router that fixes the issue, otherwise I'll be going back to DropBox.
KnotProfit
 
Posts: 11
Joined: Wed Feb 19, 2014 5:10 pm
Location: Cople, OH

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby Tony » Mon Feb 24, 2014 1:34 pm

Hi,

Thanks for the update!
As long as the traffic can reach the gateway you should not have a problem. Something to consider is that I believe your current router is also acting as your cable modem, so it would still be fronting a new router, unless it was replaced as well. After some brief searching, it sounds like it could be a hassle getting the modem to play nice with another router (setting it up in bridge mode), but it can be done. I'm sure you've seen, as I have, the many complaints about this particular router/modem, especially with port forwarding.

I am certainly willing to help in any way I can.
User avatar
Tony
 
Posts: 100
Joined: Tue Nov 19, 2013 2:47 pm

Re: Connecting clients to your gateway (Ports and Firewalls)

Postby KnotProfit » Mon Feb 24, 2014 3:26 pm

I'm going to see if I can get a different model or even brand. Can you post the link to where you saw how to set up the router in bridge mode if you still have it handy? Worst case I'll take a Saturday and see if I can get that going.

Thanks,
KnotProfit
 
Posts: 11
Joined: Wed Feb 19, 2014 5:10 pm
Location: Cople, OH

Next

Return to odrive Beta!



cron